re = /(?<=Application Name:\s{7})[^\n]*(?=[^=]*(?=Secret Key))|(?<=Secret Key:\s{13})[^\n]*/
str = 'Application Details for the XYZ application:
=========================================================
Application Name: XYXZW
Application Id: XYZ353WERX
Secret Key: XYZ86JBHHSD
Application Details for the XYZ application:
=========================================================
Application Name: XYXZW
Application Id: XYZ353WERX
Application Details for the XYZ application:
=========================================================
Application Name: XYXZW
Application Id: XYZ353WERX
Secret Key: XYZ86JBHHSD
Application Details for the XYZ application:
=========================================================
Application Name: XYXZW
Application Id: XYZ353WERX'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end