using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\D|^)(?!2016\b)(\d{3,})";
string input = @"123 Employee ID DF856, Year 2016, Department Finance, Team 2, Location 112";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}