$re = '/(?:\D|^)(?!2016\b)(\d{3,})/m';
$str = '123 Employee ID DF856, Year 2016, Department Finance, Team 2, Location 112';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);