re = /(?:\D|^)(?!2016\b)(\d{3,})/m
str = '123 Employee ID DF856, Year 2016, Department Finance, Team 2, Location 112'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end