const regex = /\{[^{}]*\}[^{}]+p\. [0-9]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\{[^{}]*\\}[^{}]+p\\. [0-9]+', 'gm')
const str = `{Hello}, [1234] (Test). This is sample data used to answer a question {Hello2} [Ch.8 p. 87 gives more information about...
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}