re = /\{[^{}]*\}[^{}]+p\. [0-9]+/m
str = '{Hello}, [1234] (Test). This is sample data used to answer a question {Hello2} [Ch.8 p. 87 gives more information about...
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end