import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "parent\\s*\\{\\s*type\\s*\\{[^\\{\\}]*subtype\\s+TestSubType\\s*\\{[^\\{\\}]*element\\s+TestElement\\s*\\{[^\\{\\}]*attributes\\s*\\{[^\\{\\}]*value\\s+testvalue[^\\{\\}]*\\}[^\\{\\}]*owner\\s+person1";
final String string = "parent {\n"
+ " type {\n"
+ " subtype TestSubType {\n"
+ " element TestElement {\n"
+ " attributes {\n"
+ " name testname;\n"
+ " description testdescription;\n"
+ " count 1234;\n"
+ " value testvalue;\n"
+ " }\n"
+ " owner person1;\n"
+ " }\n"
+ " }\n"
+ " subtype TestSubType1 {\n"
+ " element TestElement1 {\n"
+ " attributes {\n"
+ " name testname1;\n"
+ " description testdescription1;\n"
+ " count 1;\n"
+ " value 1\n"
+ " }\n"
+ " owner person2;\n"
+ " }\n"
+ " }\n"
+ " subtype TestSubType2 {\n"
+ " element TestElement2 {\n"
+ " attributes {\n"
+ " name testname2;\n"
+ " description testdescription2;\n"
+ " count 2;\n"
+ " value 2\n"
+ " }\n"
+ " owner unknown;\n"
+ " }\n"
+ " }\n"
+ " subtype TestSubType3 {\n"
+ " element TestElement3 {\n"
+ " attributes {\n"
+ " name testname3;\n"
+ " description testdescription3;\n"
+ " count 3;\n"
+ " value 3\n"
+ " }\n"
+ " owner unknown;\n"
+ " }\n"
+ " }\n"
+ " subtype TestSubType3 {\n"
+ " element TestElement4 {\n"
+ " attributes {\n"
+ " name testname4;\n"
+ " description testdescription4;\n"
+ " count 4;\n"
+ " value 4\n"
+ " }\n"
+ " owner unknown;\n"
+ " }\n"
+ " }\n"
+ " subtype TestSubType4 {\n"
+ " element TestElement5 {\n"
+ " attributes {\n"
+ " name testname5;\n"
+ " description testdescription5;\n"
+ " count 5;\n"
+ " value 5\n"
+ " }\n"
+ " owner unknown;\n"
+ " }\n"
+ " }\n"
+ " subtype TestSubType5 {\n"
+ " element TestElement6 {\n"
+ " attributes {\n"
+ " name testname6;\n"
+ " description testdescription6;\n"
+ " count 6;\n"
+ " value 6\n"
+ " }\n"
+ " owner unknown;\n"
+ " }\n"
+ " }\n"
+ " subtype TestSubType6 {\n"
+ " element TestElement7 {\n"
+ " attributes {\n"
+ " name testname7;\n"
+ " description testdescription7;\n"
+ " count 7;\n"
+ " value 7\n"
+ " }\n"
+ " owner unknown;\n"
+ " }\n"
+ " }\n"
+ " subtype TestSubType7 {\n"
+ " element TestElement8 {\n"
+ " attributes {\n"
+ " name testname8;\n"
+ " description testdescription8;\n"
+ " count 8;\n"
+ " value 8\n"
+ " }\n"
+ " owner unknown;\n"
+ " }\n"
+ " }\n"
+ " subtype TestSubType8 {\n"
+ " element TestElement9 {\n"
+ " attributes {\n"
+ " name testname9;\n"
+ " description testdescription9;\n"
+ " count 9;\n"
+ " value 9\n"
+ " }\n"
+ " owner unknown;\n"
+ " }\n"
+ " }\n"
+ " subtype TestSubType9 {\n"
+ " element TestElement10 {\n"
+ " attributes {\n"
+ " name testname10;\n"
+ " description testdescription10;\n"
+ " count 10;\n"
+ " value 10\n"
+ " }\n"
+ " owner unknown;\n"
+ " }\n"
+ " }\n"
+ " subtype TestSubType10 {\n"
+ " element TestElement11 {\n"
+ " attributes {\n"
+ " name testname11;\n"
+ " description testdescription11;\n"
+ " count 11;\n"
+ " value 11\n"
+ " }\n"
+ " owner unknown;\n"
+ " }\n"
+ " }\n"
+ " }\n"
+ "}\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}