package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)^[a-z]+:\/\/|\.?[^/.\s]+`)
var str = `http://test.test.again.mail.yahoo.com/blah/blah`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}