$re = '/^[a-z]+:\/\/|\.?[^/.\s]+/yi';
$str = 'http://test.test.again.mail.yahoo.com/blah/blah';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);