re = /^[a-z]+:\/\/|\.?[^\/.\s]+/i
str = 'http://test.test.again.mail.yahoo.com/blah/blah'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end