package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\b[a-z][a-z0-9_]*(\.[a-z0-9_]+)+[0-9a-z_]\b`)
var str = `id= com.mycomp.war.tasks.JmxMetricsTask I run/id-geLh3hM1-1_2 [Svc--DAG]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}