$re = '/\b[a-z][a-z0-9_]*(\.[a-z0-9_]+)+[0-9a-z_]\b/i';
$str = 'id= com.mycomp.war.tasks.JmxMetricsTask I run/id-geLh3hM1-1_2 [Svc--DAG]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);