re = /\b[a-z][a-z0-9_]*(\.[a-z0-9_]+)+[0-9a-z_]\b/i
str = 'id= com.mycomp.war.tasks.JmxMetricsTask I run/id-geLh3hM1-1_2 [Svc--DAG]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end