using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"location=""(.*?)""";
string input = @"<xxxx location=""file path/level1/level2"" xxxx some=""xxx"">
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}