re = /location="(.*?)"/
str = '<xxxx location="file path/level1/level2" xxxx some="xxx">
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end