package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`location="(.*?)"`)
var str = `<xxxx location="file path/level1/level2" xxxx some="xxx">
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}