package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^:\n]*:.*(*SKIP)(*FAIL)|\)`)
var str = `Hello1 (
First : (),
Second )
Hello2 (
First
)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}