#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^http\:\/\/[0-9]+|[a-z]+|[0-9][a-z]+|[a-z][0-9]+\.[a-z]+\/[a-z]+|[0-9]+|[0-9][a-z]+|[a-z][0-9]+\/[0-9]+|[a-z]+|[0-9][a-z]+|[a-z][0-9]+(?!\.jpg|jpeg|png|gif)"
Local $sString = "http://site234.com/folder/ar.txt" & @CRLF & _
"http://jtem.com/folder/s.zip" & @CRLF & _
"http://site.com/folder/ddr" & @CRLF & _
"http://sit23e1.ru/folder/eff.jpg" & @CRLF & _
"http://spbrecommender.com/folder/karo.gif" & @CRLF & _
"http://site.eu/folder/spb.pdf" & @CRLF & _
"http://site.com/folder/lego.jpeg" & @CRLF & _
"http://sir.fr/folder/some.jpg" & @CRLF & _
"http://site.com/folder/erro.exe" & @CRLF & _
"http://personel.com/folder/1.png"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")