use strict;
my $str = 'http://site234.com/folder/ar.txt
http://jtem.com/folder/s.zip
http://site.com/folder/ddr
http://sit23e1.ru/folder/eff.jpg
http://spbrecommender.com/folder/karo.gif
http://site.eu/folder/spb.pdf
http://site.com/folder/lego.jpeg
http://sir.fr/folder/some.jpg
http://site.com/folder/erro.exe
http://personel.com/folder/1.png';
my $regex = qr/^http\:\/\/[0-9]+|[a-z]+|[0-9][a-z]+|[a-z][0-9]+\.[a-z]+\/[a-z]+|[0-9]+|[0-9][a-z]+|[a-z][0-9]+\/[0-9]+|[a-z]+|[0-9][a-z]+|[a-z][0-9]+(?!\.jpg|jpeg|png|gif)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}