import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^http\\:\\/\\/[0-9]+|[a-z]+|[0-9][a-z]+|[a-z][0-9]+\\.[a-z]+\\/[a-z]+|[0-9]+|[0-9][a-z]+|[a-z][0-9]+\\/[0-9]+|[a-z]+|[0-9][a-z]+|[a-z][0-9]+(?!\\.jpg|jpeg|png|gif)";
final String string = "http://site234.com/folder/ar.txt\n"
+ "http://jtem.com/folder/s.zip\n"
+ "http://site.com/folder/ddr\n"
+ "http://sit23e1.ru/folder/eff.jpg\n"
+ "http://spbrecommender.com/folder/karo.gif\n"
+ "http://site.eu/folder/spb.pdf\n"
+ "http://site.com/folder/lego.jpeg\n"
+ "http://sir.fr/folder/some.jpg\n"
+ "http://site.com/folder/erro.exe\n"
+ "http://personel.com/folder/1.png";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}