using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b([aei]*h*[aei]+h[haei]+|[aei]*y*[aei]+y[yaei]*|o?l+o+l+[ol]*)\b";
string input = @"hahahahhhahahahhahahaa";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}