re = /\b([aei]*h*[aei]+h[haei]+|[aei]*y*[aei]+y[yaei]*|o?l+o+l+[ol]*)\b/m
str = 'hahahahhhahahahhahahaa'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end