$re = '/\b([aei]*h*[aei]+h[haei]+|[aei]*y*[aei]+y[yaei]*|o?l+o+l+[ol]*)\b/m';
$str = 'hahahahhhahahahhahahaa';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);