#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\s*(.*\S)\s*\((\d{4})\)"
Local $sString = "movieId title genres" & @CRLF & _
"Toy Story (1995)" & @CRLF & _
"Jumanji (1995)" & @CRLF & _
"Grumpier Old Men (1995)" & @CRLF & _
"Waiting to Exhale (1995)" & @CRLF & _
"Father of the Bride Part II (1995)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")