package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s*(.*\S)\s*\((\d{4})\)`)
var str = `movieId title genres
Toy Story (1995)
Jumanji (1995)
Grumpier Old Men (1995)
Waiting to Exhale (1995)
Father of the Bride Part II (1995)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}