const regex = /\s*(.*\S)\s*\((\d{4})\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s*(.*\\S)\\s*\\((\\d{4})\\)', 'gm')
const str = `movieId title genres
Toy Story (1995)
Jumanji (1995)
Grumpier Old Men (1995)
Waiting to Exhale (1995)
Father of the Bride Part II (1995)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}