using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\s+)?(\[)?database(\])?\.(\[)?dbo(\]?)\.(\[?)table_name(\]?)((\s+)(tn))? (\s+)?";
string input = @" database.dbo.table_name
database.dbo.table_name tn
[database].[dbo].[table_name]
database.[dbo].[table_name]
database.dbo.[table_name] tn
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}