$re = '/(\s+)?(\[)?database(\])?\.(\[)?dbo(\]?)\.(\[?)table_name(\]?)((\s+)(tn))? (\s+)?/';
$str = ' database.dbo.table_name
database.dbo.table_name tn
[database].[dbo].[table_name]
database.[dbo].[table_name]
database.dbo.[table_name] tn
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);