package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\s+)?(\[)?database(\])?\.(\[)?dbo(\]?)\.(\[?)table_name(\]?)((\s+)(tn))? (\s+)?`)
var str = ` database.dbo.table_name
database.dbo.table_name tn
[database].[dbo].[table_name]
database.[dbo].[table_name]
database.dbo.[table_name] tn
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}