package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z',.\s-]{1,25}$`)
var str = `St. Clou$$
New York
Prai!@rie
Houston
$t. Thomas
Chicago
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}