re = /^[a-zA-Z',.\s-]{1,25}$/m
str = 'St. Clou$$
New York
Prai!@rie
Houston
$t. Thomas
Chicago
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end