$re = '/^[a-zA-Z\',.\s-]{1,25}$/m';
$str = 'St. Clou$$
New York
Prai!@rie
Houston
$t. Thomas
Chicago
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);