package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:ecp\.eset\.systems|(?:(?:m\.)?esa|h1\-esa0[1-4]|h3\-esa2\-0[1-4]\-v)\.eset\.com)$`)
var str = `ecp.eset.systems
esa.eset.com
m.esa.eset.com
h1-esa01.eset.com
h1-esa02.eset.com
h1-esa03.eset.com
h1-esa04.eset.com
h3-esa2-01-v.eset.com
h3-esa2-02-v.eset.com
h3-esa2-03-v.eset.com
h3-esa2-04-v.eset.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}