use strict;
my $str = 'ecp.eset.systems
esa.eset.com
m.esa.eset.com
h1-esa01.eset.com
h1-esa02.eset.com
h1-esa03.eset.com
h1-esa04.eset.com
h3-esa2-01-v.eset.com
h3-esa2-02-v.eset.com
h3-esa2-03-v.eset.com
h3-esa2-04-v.eset.com';
my $regex = qr/^(?:ecp\.eset\.systems|(?:(?:m\.)?esa|h1\-esa0[1-4]|h3\-esa2\-0[1-4]\-v)\.eset\.com)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}