# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:ecp\.eset\.systems|(?:(?:m\.)?esa|h1\-esa0[1-4]|h3\-esa2\-0[1-4]\-v)\.eset\.com)$"
test_str = ("ecp.eset.systems\n"
"esa.eset.com\n"
"m.esa.eset.com\n"
"h1-esa01.eset.com\n"
"h1-esa02.eset.com\n"
"h1-esa03.eset.com\n"
"h1-esa04.eset.com\n"
"h3-esa2-01-v.eset.com\n"
"h3-esa2-02-v.eset.com\n"
"h3-esa2-03-v.eset.com\n"
"h3-esa2-04-v.eset.com")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.