using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"subcategory\.html\?.*id=(.*?)&(.*title=(.+)?)?";
string input = @"http://example.com/xyz/subcategory.html?id=3000080292&backTitle=Back&title=BabySale
http://example.com/xyz/subcategory.html?id=3000080292&backTitle=Back&";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}