// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)subcategory\.html\?.*id=(.*?)&(.*title=(.+)?)?").unwrap();
let string = "http://example.com/xyz/subcategory.html?id=3000080292&backTitle=Back&title=BabySale
http://example.com/xyz/subcategory.html?id=3000080292&backTitle=Back&";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}