#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)[~!@#$%^&*(){}_\\<>?\[\]|-]"
Local $sString = "~!@#$%^&*(){}_\<>?[]|-"
Local $sSubst = "\\$0"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)