re = /[~!@#$%^&*(){}_\\<>?\[\]|-]/m
str = '~!@#$%^&*(){}_\\<>?[]|-'
subst = '\\\\$0'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result