import re
regex = re.compile(r"[~!@#$%^&*(){}_\\<>?\[\]|-]", flags=re.MULTILINE)
test_str = "~!@#$%^&*(){}_\\<>?[]|-"
subst = "\\\\$0"
result = regex.sub(subst, test_str)
if result:
print(result)