using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a .*? href=""(.*?)"".*?>(?>.*?<\/a>)";
string input = @"<a class=""..."" href=""..."" ..="".."">My Text</a>
<a class=""..."" href=""http"" ..="".."">My Text</a>
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}