re = /<a .*? href="(.*?)".*?>(?>.*?<\/a>)/m
str = '<a class="..." href="..." ..="..">My Text</a>
<a class="..." href="http" ..="..">My Text</a>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end