$re = '/<a .*? href="(.*?)".*?>(?>.*?<\/a>)/m';
$str = '<a class="..." href="..." ..="..">My Text</a>
<a class="..." href="http" ..="..">My Text</a>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);