import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^PROC SQL;.*\\n(?:(?!RUN;|QUIT;).*\\n)*(?:RUN|QUIT);";
final String string = "kkkkk;\n\n"
+ " select xx(\"xE'\", PUT(xx.xxxx.),\"'\") jdfjhf:jhfjj from xxxx_x_xx_L ;\n"
+ "quit; \n\n"
+ "/* 1.xxxxx FROM xxxx_x_Ex_x */ \n"
+ "proc sql; (\"TRUuuuth\");\n"
+ "hhhjhfjs as fdsjfsj:\n"
+ "select * from djfkjd to jfkjs\n"
+ "(\n"
+ "SELECT abc AS abc1, abc_2_ AS efg, abc_fg, fkdkfj_vv, jjsflkl_ff, fjkdsf_jfkj\n"
+ " FROM &xxx..xxx_xxx_xxE\n"
+ "where ((xxx(xx_ix as format 'xxxx-xx') gff &jfjfsj_jfjfj.) and \n"
+ " (xxx(xx_ix as format 'xxxx-xx') lec &jgjsd_vnv.))\n"
+ " );\n\n"
+ "1)\n\n"
+ "jjjjjj;\n\n"
+ " select xx(\"xE'\", PUT(xx.xxxx.),\"'\") jdfjhf:jhfjj from xxxx_x_xx_L ;\n"
+ "quit; \n\n"
+ "/* 1.xxxxx FROM xxxx_x_Ex_x */ ()\n"
+ "PROC SQL; (\"CUuuiiiiuth\");\n"
+ "hhhjhfjs as fdsjfsj:\n"
+ "select * from djfkjd to jfkjs\n"
+ "(SELECT abc AS abc1, abc_2_ AS efg, abc_fg, fkdkfj_vv, jjsflkl_ff, fjkdsf_jfkj\n"
+ " FROM &xxx..xxx_xxx_xxE\n"
+ "where ((xxx(xx_ix as format 'xxxx-xx') gff &jfjfsj_jfjfj.) and \n"
+ " (xxx(xx_ix as format 'xxxx-xx') lec &jgjsd_vnv.))(( ))\n"
+ " );\n\n"
+ "2)(\n\n"
+ "RUN;\n\n"
+ "())\n\n"
+ "------------\n"
+ ")";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}