import re
regex = re.compile(r"^PROC SQL;.*\n(?:(?!RUN;|QUIT;).*\n)*(?:RUN|QUIT);", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("kkkkk;\n\n"
" select xx(\"xE'\", PUT(xx.xxxx.),\"'\") jdfjhf:jhfjj from xxxx_x_xx_L ;\n"
"quit; \n\n"
"/* 1.xxxxx FROM xxxx_x_Ex_x */ \n"
"proc sql; (\"TRUuuuth\");\n"
"hhhjhfjs as fdsjfsj:\n"
"select * from djfkjd to jfkjs\n"
"(\n"
"SELECT abc AS abc1, abc_2_ AS efg, abc_fg, fkdkfj_vv, jjsflkl_ff, fjkdsf_jfkj\n"
" FROM &xxx..xxx_xxx_xxE\n"
"where ((xxx(xx_ix as format 'xxxx-xx') gff &jfjfsj_jfjfj.) and \n"
" (xxx(xx_ix as format 'xxxx-xx') lec &jgjsd_vnv.))\n"
" );\n\n"
"1)\n\n"
"jjjjjj;\n\n"
" select xx(\"xE'\", PUT(xx.xxxx.),\"'\") jdfjhf:jhfjj from xxxx_x_xx_L ;\n"
"quit; \n\n"
"/* 1.xxxxx FROM xxxx_x_Ex_x */ ()\n"
"PROC SQL; (\"CUuuiiiiuth\");\n"
"hhhjhfjs as fdsjfsj:\n"
"select * from djfkjd to jfkjs\n"
"(SELECT abc AS abc1, abc_2_ AS efg, abc_fg, fkdkfj_vv, jjsflkl_ff, fjkdsf_jfkj\n"
" FROM &xxx..xxx_xxx_xxE\n"
"where ((xxx(xx_ix as format 'xxxx-xx') gff &jfjfsj_jfjfj.) and \n"
" (xxx(xx_ix as format 'xxxx-xx') lec &jgjsd_vnv.))(( ))\n"
" );\n\n"
"2)(\n\n"
"RUN;\n\n"
"())\n\n"
"------------\n"
")")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")