$re = '/^PROC SQL;.*\n(?:(?!RUN;|QUIT;).*\n)*(?:RUN|QUIT);/im';
$str = 'kkkkk;
select xx("xE\'", PUT(xx.xxxx.),"\'") jdfjhf:jhfjj from xxxx_x_xx_L ;
quit;
/* 1.xxxxx FROM xxxx_x_Ex_x */
proc sql; ("TRUuuuth");
hhhjhfjs as fdsjfsj:
select * from djfkjd to jfkjs
(
SELECT abc AS abc1, abc_2_ AS efg, abc_fg, fkdkfj_vv, jjsflkl_ff, fjkdsf_jfkj
FROM &xxx..xxx_xxx_xxE
where ((xxx(xx_ix as format \'xxxx-xx\') gff &jfjfsj_jfjfj.) and
(xxx(xx_ix as format \'xxxx-xx\') lec &jgjsd_vnv.))
);
1)
jjjjjj;
select xx("xE\'", PUT(xx.xxxx.),"\'") jdfjhf:jhfjj from xxxx_x_xx_L ;
quit;
/* 1.xxxxx FROM xxxx_x_Ex_x */ ()
PROC SQL; ("CUuuiiiiuth");
hhhjhfjs as fdsjfsj:
select * from djfkjd to jfkjs
(SELECT abc AS abc1, abc_2_ AS efg, abc_fg, fkdkfj_vv, jjsflkl_ff, fjkdsf_jfkj
FROM &xxx..xxx_xxx_xxE
where ((xxx(xx_ix as format \'xxxx-xx\') gff &jfjfsj_jfjfj.) and
(xxx(xx_ix as format \'xxxx-xx\') lec &jgjsd_vnv.))(( ))
);
2)(
RUN;
())
------------
)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);