$re = '/(?<my_field_1>\w\w\w)\S*(?<myfield_2>\d\d\d\d)/m';
$str = 'This the location for ABC-1234-56-7890';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);