re = /(?<my_field_1>\w\w\w)\S*(?<myfield_2>\d\d\d\d)/m
str = 'This the location for ABC-1234-56-7890'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end