import re
regex = re.compile(r"(?<my_field_1>\w\w\w)\S*(?<myfield_2>\d\d\d\d)", flags=re.MULTILINE)
test_str = "This the location for ABC-1234-56-7890"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")