#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\[?(new|evo|bug|wf)(?:[^0-9]{0,5}(?<!op)(?<!op )([0-9]{5,}))? ?-?_?\|?\]? ?"
Local $sString = "EVO156484 - ajout avec solde PRI (O/N)" & @CRLF & _
"EVO158604 - [GC] Ajout gestion type transport hors moisson" & @CRLF & _
"Evo158595 [676M] - OP19068 Integration factures Immo et" & @CRLF & _
"Evo158595 [676M] - OP 19068 Integration factures Immo et" & @CRLF & _
"Evo OP19068 Integration factures Immo et" & @CRLF & _
"Evo OP 19068 Integration factures Immo et" & @CRLF & _
"158595 - 676M - OP19068 Integration factures Immo et creat" & @CRLF & _
"BUG 160585 Interdire la saisie des temps sur le mois après" & @CRLF & _
"BUG-[DSN] Implementation bloc 42 pour CVAE" & @CRLF & _
"BUG153922-[DSN] Resolution pb bloc signataire/creation" & @CRLF & _
"BUGXXXXXX - [GC] passer entete.zon-int-4 a 0" & @CRLF & _
"BUG159220 - En MODEXP si modif Mode reg et mt reg ne" & @CRLF & _
"BUG - Ensi 159220 et" & @CRLF & _
"Bug888888 - [EMI] retouche pour le window.close" & @CRLF & _
"BUG159417 - [GC][MNT157789] Correction controle phyto saisi" & @CRLF & _
"[DSN][GRH][WF160820] PB sur les libelles des Types et codes" & @CRLF & _
"Evo157633 - 560- OP19043 - Mise à disposition d'une extract" & @CRLF & _
"Evo157633 - 560 - OP19043 - Extraction complete de mouvemen" & @CRLF & _
"BUG|159471|Calcul des % d'avancement totaux facture dièses" & @CRLF & _
"160112 TDB3 ajout diese 52 et 53 reste a receptionner et su" & @CRLF & _
"BUG156820 #43 du type port avec enlevement client chargé qu" & @CRLF & _
"BUG156820_#43 du type port avec enlevement client chargé qu" & @CRLF & _
"BUG 153322suite L'engagé est un BTE composé des CDF non réc"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")